
 

 
Practical 3, Part 2: Tomography Segmentation with IMOD 
(version 4.9.{x}) – Segmenting microtubules and vesicles from a 
{human neuronal cell} tomogram.  

 
 

AIMS 
In Part 2 of this Practical you will learn how to use several 
IMOD tools to highlight biological structures visible in the
tomogram reconstructed in Part 1. 
In particular, you will learn how to: 
• segment elongated/tubular structures, like microtubules

(section 2) 
• segment globular/spherical structures, like vesicles 

(section 3) 
• make a movie of the final segmentation (section 4) 



Section 1: Preparation 
 

1A Open your reconstructed tomogram, as explained in the last section 
of Practical 3, Part 1.  
Before starting the segmentation, make sure you have setup the 
correct pixel size for your model. Go to “Menubar > Edit > Model 
> Header”. Make sure this contains the correct pixel size of the 
tomogram, in our case it should be 1.688 nm. 

1B Be sure you are in “Model” mode, or switch to Model in the main 
“3dmod window”. 

 



1C Open the “3Dmod Model View” window by pressing the “v” key or 
by clicking on “Menubar > Image > Model View”. 
 

 
 
 
 
 

Section 2: Microtubule Segmentation 
 

2A Create a New Object:  
 
Go to “Menubar > Edit > Object > New” and give the object an 
appropriate name (e.g.: "Microtubule1"). Select the “Object type” as 
Open. This option will allow to create an open contour object (e.g. a 
line) in which the first point is not connected to the last point. 
Determine the inner radius (half the diameter) of your microtubules 
in pixels. In our case, it should be approximately 7 pixels. Type the 
radius in the field “Sphere radius for points”. This sphere size is set 
just to help you see where you've put points, so don't worry if the 
spheres are too large. 



 
Another helpful segmentation tool is the choice of a symbol to mark 
each point. For example, in the “Symbol” field you can choose 
triangle with size 3 and tick (✔ mark ends: this will project a triangle 
over each point and also marks the first and last point in the contour 
with a red and green cross respectively. 
 

 
2B Draw points as contours. 

 
In the ZAP window of the tomogram, use the keys [PgUp] and 
[PgDown] to locate one end of a microtubule and the key [+] or 
[-] to zoom/unzoom in the area. Once you locate it, left-click at the  



 
centre of the microtubule. Place the first point by clicking the 
middle mouse button. You will be able to see a point in the “3dmod 
Model View” window and you can use the scroll wheel of the mouse 
to zoom in and out of the model. 

 
2C Draw a line by placing multiple points in the same contours. 

 
Place the second point at a distance of approximately 4-6 times the 
diameter of the microtubule by middle-click. In the “3dmod Model 
View” you will see two dots joined by a line. This means that the 
two points are part of the same contour (group of points). 

If you don’t see the line connecting the two dots in the “3dmod 
Model View” you accidentally created a new contour. To avoid 
creation of new contours, be sure the last inserted point is selected: 
usually a yellow cross or circle surrounds the centre of the last 
placed point, making it selected.  



 
Once a new point is created by middle-click, it should be also 
automatically selected. However, sometimes a left-click in the ZAP 
window may cause the deselection of the last point, resulting in 
creating a new contour, breaking the line.  

In this case the easiest thing to do is to delete the last point inserted, 
select the second-last inserted point by left-click, and place the new 
point using the middle-click, as usual. Alternatively, two contours 
can be joined by selecting the separate segments using [CTRL+left 
click] and by joining them using [SHIFT+j]. 

 



2D Keep placing points till you reach the other end of the microtubule, 
trying to avoid the creation of new contours. If the microtubule is 
not perfectly centred in the plane of the section, use the [PgUp] 
and [PgDown] to slice the tomogram in the Z direction, and place 
the point at its correct centre.  
 
If any of the point is slightly misplaced from the microtubule, you 
can select it with left-click and move it with right-click at the 
amended position. 

 



2E Meshing the model 
To create a tube mesh, select the Model View Window then click 
"Menubar > Edit > Objects ...". In this objects window, tick 
(✔ Tubes in the “Meshing” field and enter the value of diameter in 
pixels in the Diam box, to set the diameter of the tube.  
We calculated the diameter of the microtubule earlier, 
approximately 14 pixels. Once the correct diameter is set, click 
"Mesh One" and you will see your tubes generate as mesh.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Note that you will have to click "Mesh One" to regenerate this mesh 
each time, and you can switch back to the normal view by changing 
the "Draw Data Type" between Mesh and Contour.  
You might also want to hide spheres by clicking Points and then tick 
the option (✔ Skip if drawing mesh. 
 
OPTIONAL: 
To change the mesh color, click on “Fill Color” and tick the (✔ Use 
fill color option, then slide Red, Green and Blue bars until the 
preferred color is displayed. 
To make the 3D effect pop, click on “Material” and play with the 
bars to adjust lights and shadows of the model until the preferred 
effect is reached. 

2F Segment more microtubules 
 
You can now segment more microtubules, this can be done in two 
alternative ways 

• by creating a new object (go to point 2A)  
• by creating a new contour (go to point 2B) 

Creating a new contour instead of a new object is quicker, as you 
don’t have to select every time the “Open”, “Object type” and 
“Sphere radius for points”. However, the advantage of segmenting 
new microtubules as new objects is that you can deal with each 
microtubule separately, with different colours, or excluding a subset 
of objects from visualization.  
 
To get the result shown below, we segmented the different 
microtubules as different objects as from point 2A. 



 
 

 
 
  



Section 3: Vesicle Segmentation 
 

3A Getting started 
Keep the “3dmod Model View” window open and create a new object 
(Menubar > Edit > Object > New), You may name it as “vesicle 
1” and in this case, make sure that the Object type is marked as 
“Closed”. 

3B Localize a vesicle 
Localize a vesicle in the tomogram using [PgUp] and [PgDown] to 
slice it, as usual. Going through the sections you may notice that for 
some sections the edges of some vesicles are barely visible, if not 
visible at all. This is due to the missing wedge effect, an intrinsic ET 
technique artefact caused by the restricted range of tilting angles, 
which limits the amount of information obtainable from the object. 
Here we first segment the visible part of the vesicle, and then we 
show how to interpolate not-visible regions. Although it is good 
practice to avoid segmenting what you cannot see, it is up to the 
investigator to decide whether or not segmenting those regions. 
 

 
 
 
 
 
 
 
 
 
 
 
 



3C Open “Menubar > Special > Drawing Tools” and select the 
“Normal” option in the Drawing Mode field. 

 

 
3D 

 
 

Draw a line around the vesicle. 
To draw a line, you first need to left-click on the vesicle, then with 
the middle mouse button clicked, draw a complete circular line. You 
will be able to see the circular line in the “3dmod Model View” 
window. 

3E Draw lines around the vesicle at different Z-coordinate planes  
Navigate through the sections and draw other complete circles along 
the vesicle as different contours, as just described in point 3D: first, 
left-click to de-select the contour at the previous section and then 
use the middle mouse button to actually draw the circle. Every circle 
in every section should be a different contour. In the “3d Model 
View” you can zoom by scrolling the mouse, and you should see 
several circles, corresponding to the vesicle segmented at different 
sections: 



 
3F Interpolate intermediate contours  

To interpolate missing segmented sections, the “Menubar > Special 
> Interpolator” is a very useful tool. Select “Smooth” in the 
Interpolator Type field. Then left-click on a vesicle contour to select it. 
Click on “Interpolate Contour” or press the [Enter] key to apply the 
interpolation. The interpolated contours are now visible on the 
“3dmod Model View”. 
 

 



3G Mesh the contours 
You can now mesh the contours using the Object Window in the 
“3dmod Model View > Edit > Objects”: select the vesicle object, 
go to the Meshing tab and click “Mesh One”. 

 
3H Interpolate missing regions (i.e. guess) 

 
If you want to interpolate the vesicle regions invisible because of 
missing wedge, you can use the “Spherical” option as type of 
interpolation in the “Interpolator” window. This assumes the object 
is spherical and approximates the missing regions to a sphere. You 
can click “Interpolate Contour” or hit the [Enter] key to create the 
interpolation, and then apply again the mesh effect to see the result 
in the “3dmod Model View” window: 



 
 

 
To smoothen the interpolation lines, tick Surface in the Meshing tab 
and increase the “Z inc” value to 3 or 4. 
You can scroll through the sections using [PgUp] and [PgDown] 
and use the drawing tools “Special > Drawing Tools” to refine the 
interpolated contours. At this point, check whether you are happy 
with the interpolated sections, especially with the “guessed” ones. 
You may remove undesired contours by using [delete], or accept 
correct contours you are happy about by pressing [enter]. Moreover, 
you can try new interpolation types and create new interpolations 
until you are satisfied with the tomogram segmentation. 
 
 



3I Segment more vesicles 
 
As an exercise you can segment other vesicles as new objects. Below, 
the result of the segmentation of two vesicles: 

 
 
 
 
 
 
 
 
 

3J Display extra information 
 
To include tomographic views in the model window, go to “Edit > 
Image” in the “3dmod Model View” and check the boxes (✔ “view 
X image”, (✔ “view Y image” and (✔ “view Z image”. This will 
make the planes of the tomogram appear in the black background 
of the “3dmod Model View”, in between the segmented objects.  
Adjust the X, Y, Z slice positions, contrast and transparency of the 
tomogram using the Black Level/White level and Transparency bars. To 
auto-adjust the contrast simply press “Use 3dmod Black/White”. 
 
 



If you need to reorient the tomogram in the original position, in 
“3dmod Model View” click “HotKeys > Model Orientation and 
Zoom > Show top of the model”. 

 

When you are satisfied with the segmented model and you have 
chosen the perfect position of the tomogram to visualize your 
features of interest (microtubules, vesicles, both…), you can start 
acquiring a movie of your 3D model. 

 



Section 4: Make a Movie (requires ImageJ/Fiji) 
 

4A Getting started 
In the “3dmod window” set the “Mode” as Movie and open 
“Menubar > File > Movie/Montage”. 
 

 

4B Set the scene and generate movie frames 
In the “3dmod Model View” window adjust the model in the 
preferred position to show main features of interest (e.g. 
microtubules, vesicles…). When satisfied with the position, scroll 
the tomogram to set the starting frame of the movie and click Set 
Start in the “Movie/Montage” window. Do the same for the ending 
frame and click Set End. 
In the “#of movie frames” box, set the length of the movie by giving 
the total number of frames to be captured from start to end: more 



frames for longer and more detailed movies (maximum number of 
frames is the total selected frames), less frames for short and more 
dynamic movies. It is anyways possible to speed up or slow down 
the movie by adjusting the number of frames-per-second in the FPS 
box: ~28 FPS or more for fast movies, ~20 or less for slower 
movies. 
If you want the movie to loop back and forth, tick the Reverse option 
(close to Set End). 
Click “Make” to preview the movie. If you are satisfied with the 
preview, select (✔ “Write files” then click again on “Make”: this 
will write all the frames of the movie in the correct order inside your 
chosen working directory. 

 
 



4C To make more sequences of the movie, click on Set Start to start 
where the previous sequence ended, and repeat the sequence 
explained in 4B. 

4D Arrange saved movie frame into an AVI movie  (using imagej) 
The frames are written by default in the project directory, so you 
need to use an external program to make the sequence of frames 
into a real movie. 
One of the programs that can easily do that is ImageJ/Fiji.  
Simply open it by typing Fiji in a terminal and import the images 
using “File > Import > Image Sequence”. The root of the 
filename by default is “modv”, so you can input it in the “File name 
contains” field, along with the starting and ending frame numbers. 
Once the full sequence of images is imported, just save it using 
“File > Save As > AVI...” and you will create an .AVI movie of 
your final 3D segmentation. 

 


